WordPressの3.4.1までは問題なく使えていたCustom Field Gui UtilityがWordPressバージョンを3.4.2にバージョンしたら使えなくなった時は、以下の方法でcfg-utility.phpを修正する。
cfg-utility.phpは
wp-contentのpluginsにインストールしたcustom-field-gui-utilityのプラグインファイル群の中にある
cfg-utility.php内にある
add_action ('simple_edit_form', array ('cfg_utility_class', 'insert_gui'));

add_action ('edit_form_advanced', array ('cfg_utility_class', 'insert_gui'));

のように修正する。

いずれ3.4.2に対応したCustom Field Gui Utilityが出ると思うが、それまでの対応として。
参考:

http://mbdb.jp/hacks/wordpress/wp3-3-custom-field-gui-utility.html